How to Use Older Version of Firefox with Existing Profiles

There are many times when we want to go back a couple of steps and use an older version of the Firefox web browser. There could be any number of reasons for doing this, but it is not so straightforward because the user profiles have a preferences file in which the last version of Firefox is recorded. If you install an older version of Firefox and try to run it, you will be give a warning about the same and it will not allow you to run it.

The information message reads, “Using an older version of Firefox can corrupt bookmarks and browsing history already saved to an exiting Firefox profile. To protect your information, create a new profile for this installation of Firefox.”

Allow Downgrade of Firefox Browser

Here is how we can work around this problem and use an older version of Firefox:

  1. First of all make a backup of Firefox user profile folders. They can be found in %AppData%\Mozilla\Firefox\Profiles directory.
  2. Download an older version of Firefox from https://ftp.mozilla.org/pub/firefox/releases/ and install it on your system. If you use a very very old version, then it won’t work at all. My suggestion is not to downgrade more than 2 major versions. For example, if you have Firefox 104 installed, downgrade only down to version 102.
  3. Press Win+R to open the Run dialog. In it, give the command firefox –allow-downgrade. This command is needed only once.Allow Downgrade of Firefox Browser
  4. Firefox will launch, load your existing profiles and work as usual. Now you can close the browser window and start using it like before using its various shortcuts – no special command is needed anymore.

If the command does not work because it cannot find firefox, then you will have to add this parameter (–allow-downgrade) to the Firefox shortcut on your desktop. You can also use this command through the Windows Terminal, PowerShell or cmd.exe.

Allow Downgrade of Firefox Browser

If you want to downgrade to a very old version of Firefox just for experimental reasons, then you have to manually export and import the various bookmarks and other saved data. Using an older version of Firefox or any other web browser is not recommended as it could pose as a big security risk. You should always use the latest available release version of the Mozilla Firefox web browser which can be downloaded from https://getfirefox.com/.

Leave a Reply

Your email address will not be published.